Internet Outage - 500 7th Avenue
Incident Report for Touro
Resolved
This incident has been resolved.
Posted Dec 08, 2019 - 11:13 EST
Monitoring
A fix has been implemented and all Internet and phone services have been restored.
Posted Nov 26, 2019 - 07:46 EST
Investigating
We are currently investigating network issues with Touro College’s 500 7th Avenue location.
Posted Nov 25, 2019 - 20:10 EST