Microsoft Office 365 and Email
Incident Report for Touro
Resolved
This incident has been resolved by Microsoft.
Posted Nov 24, 2019 - 22:20 EST
Investigating
We are experiencing issues with Microsoft 365 passwords. Any password changes will work for your TouroOne portal, but not for your employee email on Microsoft 365.
New employees may experience a delay with email creation.

We are working to resolve this as quickly as possible.
Posted Nov 14, 2019 - 17:26 EST
This incident affected: Touro New York (Faculty/Staff Email).