Bayshore phone service outage
Incident Report for Touro
Resolved
The service has been restored
Posted Nov 27, 2019 - 15:35 EST
Investigating
We have opened a ticket with the carrier and it is being investigated.
Posted Nov 27, 2019 - 12:22 EST