Lander College for Men - Internet and Phone Service Is Unstable
Incident Report for Touro
Resolved
This incident has been resolved.
Posted Dec 26, 2019 - 13:48 EST
Monitoring
The Lander College for Men Internet, phone and network is stable. There are pockets of limited network in the dorms at 7601, 7603 & 7611. IITS will be restoring services this morning.
Posted Nov 26, 2019 - 07:46 EST
Identified
The Lander College for Men Internet, phone and network is unstable and service is intermittent. Cisco and IITS have identified the issue with the network hardware and will resolve the problem Monday morning.
Posted Nov 24, 2019 - 22:24 EST