1602 avenue J issues
Incident Report for Touro
Resolved
The problem was resolved. We enabled fail over internet circuit for future.
Posted 4 months ago. Apr 05, 2018 - 13:27 EDT
Investigating
1602 avenue J issues, there seems to be no internet, we are working on the issue.
Posted 4 months ago. Apr 04, 2018 - 14:43 EDT