Microsoft Email / Office 365 access issue
Incident Report for Touro
Resolved
As per Microsoft-

"We've confirmed restored access and functionality for all Microsoft Email and Office 365 services. Please see the admin dashboard for final details of the event."
Posted Nov 20, 2019 - 06:44 EST
Investigating
As per Microsoft-

"Microsoft Email / Office 365 access issue

Current status: We've identified that users may experience access issues with the Microsoft 365 Admin Center, Exchange Online, SharePoint Online, Microsoft Teams, Skype for Business, and Yammer."
Posted Nov 19, 2019 - 21:12 EST
This incident affected: Touro New York (Faculty/Staff Email) and NYMC (Email).