Network Slowness at NYMC Main Campus
Incident Report for Touro
Resolved
The IT Network Engineers have identified the issue and it has been resolved.
Posted Oct 28, 2019 - 14:04 EDT
Investigating
We currently experiencing network slowness at the Main campus. The IT Network Engineer team is investigating the issue. Further updates will be provided.
Posted Oct 28, 2019 - 12:10 EDT
This incident affected: NYMC (Internet, Network).