Telephone service issues at Lander college for men 75-31 150th street in queens
Incident Report for Touro
Resolved
Issue has been resolved, service is restored.
Posted 2 months ago. Sep 12, 2017 - 16:40 EDT
Monitoring
All services have been restored, we are monitoring the issue.
Posted 2 months ago. Sep 12, 2017 - 15:52 EDT
Update
This issue encompasses trouble with internet, email, wireless, TouroOne, incoming and outgoing calls as well as voicemail.
Posted 2 months ago. Sep 12, 2017 - 15:32 EDT
Investigating
we are experiencing telephone service issues in Queens at Lander College for men we are investigating the issue.
Posted 2 months ago. Sep 12, 2017 - 14:09 EDT