NYMC Email offline
Incident Report for Touro
Resolved
The NYMC email system is back online
Posted 17 days ago. Sep 04, 2017 - 12:19 EDT
Investigating
The NYMC email system is currently offline. The IT Department is aware of the problem and is working to resolve the issue ASAP.
Posted 17 days ago. Sep 04, 2017 - 11:06 EDT
This incident affected: NYMC (Email).