Email from touro.edu (New York) and tun.touro.edu (Nevada) not going through.
Incident Report for Touro
Resolved
The issue has been resolved. Backed up email is being delivered. Email is back to normal.
Posted 9 days ago. Nov 09, 2017 - 20:26 EST
Identified
Email from touro.edu email accounts on Microsoft Office 365 are currently not going through to tun.touro.edu email accounts. We are in contact with Microsoft to resolve the issue.
Posted 9 days ago. Nov 09, 2017 - 18:49 EST
This incident affected: Touro New York (Faculty/Staff Email) and Touro Nevada (Email).