TouroOne INB and SSB Outage
Incident Report for Touro
Resolved
TouroOne INB and SSB services have been restore. IITS is waiting on the root cause analysis from our vendor partner.
Posted 10 days ago. Apr 09, 2018 - 12:32 EDT
Investigating
The TouroOne INB and SSB services are currently unavailable. IITS is working with our application providing to resolve the issue.
Posted 10 days ago. Apr 09, 2018 - 11:49 EDT
This incident affected: TouroOne INB and TouroOne SSB.