Telephone service issues at 1602 ave J.
Incident Report for Touro
Resolved
Service has been restored and there have been no further issues.
Posted 16 days ago. Nov 02, 2017 - 11:14 EDT
Monitoring
Service has been restored, we are keeping an eye on it until tomorrow.
Posted 17 days ago. Nov 01, 2017 - 13:29 EDT
Investigating
Telephone service issues at 1602 ave J, they are currently unable to make calls, we have opened a ticket with the carrier and the vendor.
Posted 17 days ago. Nov 01, 2017 - 11:00 EDT